Google Cloud intermittent

Incident Report for Giftster System Status

Postmortem

Our third party hosting infrastructure had an issue that impacted Giftster, and it was resolved once the third party resolved their issue.

Posted Sep 01, 2026 - 14:23 CDT

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 14:22 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 13:20 CDT

Update

Google is in process of resolving the issue, services are slowly coming back.
Posted Sep 01, 2026 - 13:19 CDT

Investigating

We know some members are experiencing interruptions in service on all our platforms due to a provider issue.
Posted Sep 01, 2026 - 12:50 CDT
This incident affected: Giftster.com, iOS (iPhone & iPad) App, and Android App.